import Foundation
let pattern = #"(₹\s+\d+(?:,\d+)*|\d+(?:,\d+)*\s+(?:kW|kVAh?))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
You Saved ₹ 1,71,252 in 7 days
Savings: 203 kW
Consumption: 225 kVAh
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span class="highlight">$1</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)