#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*?(?:\b|\+?\b1)?(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)\b.*$"
Local $sString = " stuff before 18005551234567 stuff after"
Local $sSubst = "$1$2$3$4$5$6$7$8$9${10}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)