use strict;
my $str = ' stuff before 18005551234567 stuff after';
my $regex = qr/^.*?(?:\b|\+?\b1)?(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)\b.*$/mp;
my $subst = '$1$2$3$4$5$6$7$8$9${10}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";