import Foundation
let pattern = #"^.*?(?:\b|\+?\b1)?(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)\b.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" stuff before 18005551234567 stuff after"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3$4$5$6$7$8$9${10}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)