import re
regex = re.compile(r"^.*?(?:\b|\+?\b1)?(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)\b.*$", flags=re.MULTILINE)
test_str = " stuff before 18005551234567 stuff after"
subst = "$1$2$3$4$5$6$7$8$9${10}"
result = regex.sub(subst, test_str)
if result:
print(result)