const regex = /^.*?(?:\b|\+?\b1)?(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)(?: |\p{P})*(\d)\b.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?(?:\\b|\\+?\\b1)?(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)\\b.*$', 'gm')
const str = ` stuff before 18005551234567 stuff after`;
const subst = `$1$2$3$4$5$6$7$8$9${10}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);