import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?(?:\\b|\\+?\\b1)?(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)(?: |\\p{P})*(\\d)\\b.*$";
final String string = " stuff before 18005551234567 stuff after";
final String subst = "$1$2$3$4$5$6$7$8$9${10}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}