using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+(\w+),\s+""to contain elements matching"",\n\s+""\[data-test-id=([\w-]+)\]""\s+";
string substitution = @"screen.getByTestId(""$2"")).toBeInTheDocument(";
string input = @" expect(
filterMenuPopup,
""to contain elements matching"",
""[data-test-id=filterMenu-isSource-yes]""
);";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}