package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s+(\w+),\s+"to contain elements matching",\n\s+"\[data-test-id=([\w-]+)\]"\s+`)
var str = []byte(` expect(
filterMenuPopup,
"to contain elements matching",
"[data-test-id=filterMenu-isSource-yes]"
);`)
var substitution = []byte("screen.getByTestId("$2")).toBeInTheDocument(")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}