const regex = /\s+(\w+),\s+"to contain elements matching",\n\s+"\[data-test-id=([\w-]+)\]"\s+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+(\\w+),\\s+"to contain elements matching",\\n\\s+"\\[data-test-id=([\\w-]+)\\]"\\s+', '')
const str = ` expect(
filterMenuPopup,
"to contain elements matching",
"[data-test-id=filterMenu-isSource-yes]"
);`;
const subst = `screen.getByTestId("$2")).toBeInTheDocument(`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);