re = /\s+(\w+),\s+"to contain elements matching",\n\s+"\[data-test-id=([\w-]+)\]"\s+/
str = ' expect(
filterMenuPopup,
"to contain elements matching",
"[data-test-id=filterMenu-isSource-yes]"
);'
subst = 'screen.getByTestId("$2")).toBeInTheDocument('
result = str.sub(re, subst)
# Print the result of the substitution
puts result