import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+(\\w+),\\s+\"to contain elements matching\",\\n\\s+\"\\[data-test-id=([\\w-]+)\\]\"\\s+";
final String string = " expect(\n"
+ " filterMenuPopup,\n"
+ " \"to contain elements matching\",\n"
+ " \"[data-test-id=filterMenu-isSource-yes]\"\n"
+ " );";
final String subst = "screen.getByTestId(\"$2\")).toBeInTheDocument(";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}