# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s+(\w+),\s+\"to contain elements matching\",\n\s+\"\[data-test-id=([\w-]+)\]\"\s+"
test_str = (" expect(\n"
" filterMenuPopup,\n"
" \"to contain elements matching\",\n"
" \"[data-test-id=filterMenu-isSource-yes]\"\n"
" );")
subst = "screen.getByTestId(\"$2\")).toBeInTheDocument("
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.