import Foundation
let pattern = #"\s+(\w+),\s+"to contain elements matching",\n\s+"\[data-test-id=([\w-]+)\]"\s+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
expect(
filterMenuPopup,
"to contain elements matching",
"[data-test-id=filterMenu-isSource-yes]"
);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"screen.getByTestId("$2")).toBeInTheDocument("#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}