use strict;
my $str = ' expect(
filterMenuPopup,
"to contain elements matching",
"[data-test-id=filterMenu-isSource-yes]"
);';
my $regex = qr/\s+(\w+),\s+"to contain elements matching",\n\s+"\[data-test-id=([\w-]+)\]"\s+/p;
my $subst = 'screen.getByTestId("$2")).toBeInTheDocument(';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";