using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?ms)\""tag\"":\s*(?<tag>[^\n]+)";
string input = @"""tag"": AKAMAI/BOT/AKAMAI_CATEGORIZED
""tag"":AKAMAI/BOT/REQUEST_ANOMALY
""tag"":AKAMAI/BOT/UNKNOWN_BOT
""tag"": ASE/WEB_ATTACK/CMDI
""tag"": ASE/WEB_ATTACK/LFI
""tag"": ASE/WEB_ATTACK/PLATFORM
""tag"": ASE/WEB_ATTACK/POLICY
""tag"": ASE/WEB_ATTACK/PROTOCOL
""tag"": ASE/WEB_ATTACK/RFI
""tag"": ASE/WEB_ATTACK/SQLI
""tag"": ASE/WEB_ATTACK/WAT
""tag"": ASE/WEB_ATTACK/XSS";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}