import Foundation
let pattern = #"(?ms)\"tag\":\s*(?<tag>[^\n]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"tag": AKAMAI/BOT/AKAMAI_CATEGORIZED
"tag":AKAMAI/BOT/REQUEST_ANOMALY
"tag":AKAMAI/BOT/UNKNOWN_BOT
"tag": ASE/WEB_ATTACK/CMDI
"tag": ASE/WEB_ATTACK/LFI
"tag": ASE/WEB_ATTACK/PLATFORM
"tag": ASE/WEB_ATTACK/POLICY
"tag": ASE/WEB_ATTACK/PROTOCOL
"tag": ASE/WEB_ATTACK/RFI
"tag": ASE/WEB_ATTACK/SQLI
"tag": ASE/WEB_ATTACK/WAT
"tag": ASE/WEB_ATTACK/XSS
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)