# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?ms)\"tag\":\s*(?<tag>[^\n]+)"
test_str = ("\"tag\": AKAMAI/BOT/AKAMAI_CATEGORIZED\n"
"\"tag\":AKAMAI/BOT/REQUEST_ANOMALY\n"
"\"tag\":AKAMAI/BOT/UNKNOWN_BOT\n"
"\"tag\": ASE/WEB_ATTACK/CMDI\n"
"\"tag\": ASE/WEB_ATTACK/LFI\n"
"\"tag\": ASE/WEB_ATTACK/PLATFORM\n"
"\"tag\": ASE/WEB_ATTACK/POLICY\n"
"\"tag\": ASE/WEB_ATTACK/PROTOCOL\n"
"\"tag\": ASE/WEB_ATTACK/RFI\n"
"\"tag\": ASE/WEB_ATTACK/SQLI\n"
"\"tag\": ASE/WEB_ATTACK/WAT\n"
"\"tag\": ASE/WEB_ATTACK/XSS")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.