// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?ms)\"tag\":\s*(?<tag>[^\n]+)"#).unwrap();
let string = "\"tag\": AKAMAI/BOT/AKAMAI_CATEGORIZED
\"tag\":AKAMAI/BOT/REQUEST_ANOMALY
\"tag\":AKAMAI/BOT/UNKNOWN_BOT
\"tag\": ASE/WEB_ATTACK/CMDI
\"tag\": ASE/WEB_ATTACK/LFI
\"tag\": ASE/WEB_ATTACK/PLATFORM
\"tag\": ASE/WEB_ATTACK/POLICY
\"tag\": ASE/WEB_ATTACK/PROTOCOL
\"tag\": ASE/WEB_ATTACK/RFI
\"tag\": ASE/WEB_ATTACK/SQLI
\"tag\": ASE/WEB_ATTACK/WAT
\"tag\": ASE/WEB_ATTACK/XSS";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}