package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?ms)\"tag\":\s*(?<tag>[^\n]+)`)
var str = `"tag": AKAMAI/BOT/AKAMAI_CATEGORIZED
"tag":AKAMAI/BOT/REQUEST_ANOMALY
"tag":AKAMAI/BOT/UNKNOWN_BOT
"tag": ASE/WEB_ATTACK/CMDI
"tag": ASE/WEB_ATTACK/LFI
"tag": ASE/WEB_ATTACK/PLATFORM
"tag": ASE/WEB_ATTACK/POLICY
"tag": ASE/WEB_ATTACK/PROTOCOL
"tag": ASE/WEB_ATTACK/RFI
"tag": ASE/WEB_ATTACK/SQLI
"tag": ASE/WEB_ATTACK/WAT
"tag": ASE/WEB_ATTACK/XSS`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}