import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)\\\"tag\\\":\\s*(?<tag>[^\\n]+)";
final String string = "\"tag\": AKAMAI/BOT/AKAMAI_CATEGORIZED\n"
+ "\"tag\":AKAMAI/BOT/REQUEST_ANOMALY\n"
+ "\"tag\":AKAMAI/BOT/UNKNOWN_BOT\n"
+ "\"tag\": ASE/WEB_ATTACK/CMDI\n"
+ "\"tag\": ASE/WEB_ATTACK/LFI\n"
+ "\"tag\": ASE/WEB_ATTACK/PLATFORM\n"
+ "\"tag\": ASE/WEB_ATTACK/POLICY\n"
+ "\"tag\": ASE/WEB_ATTACK/PROTOCOL\n"
+ "\"tag\": ASE/WEB_ATTACK/RFI\n"
+ "\"tag\": ASE/WEB_ATTACK/SQLI\n"
+ "\"tag\": ASE/WEB_ATTACK/WAT\n"
+ "\"tag\": ASE/WEB_ATTACK/XSS";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}