#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)host\=\s*(?<campus_site_code>\w\d{3,5})(?<function>\w\w)"
Local $sString = "1.) host=L004PS4bldDC7, the campus site code is “L004” and the function code is “PS”" & @CRLF & _
"" & @CRLF & _
"2.) host= L0005DB5bldPS, the campus site code is “L0005” and the function code is “DB”" & @CRLF & _
"" & @CRLF & _
"3.) host=L00006DC6rDB1, the campus site code is “L00006” and the function code is “DC”"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")