use strict;
my $str = '1.) host=L004PS4bldDC7, the campus site code is “L004” and the function code is “PS”
2.) host= L0005DB5bldPS, the campus site code is “L0005” and the function code is “DB”
3.) host=L00006DC6rDB1, the campus site code is “L00006” and the function code is “DC”';
my $regex = qr/host\=\s*(?<campus_site_code>\w\d{3,5})(?<function>\w\w)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}