import re
regex = re.compile(r"host\=\s*(?<campus_site_code>\w\d{3,5})(?<function>\w\w)", flags=re.MULTILINE)
test_str = ("1.) host=L004PS4bldDC7, the campus site code is “L004” and the function code is “PS”\n\n"
"2.) host= L0005DB5bldPS, the campus site code is “L0005” and the function code is “DB”\n\n"
"3.) host=L00006DC6rDB1, the campus site code is “L00006” and the function code is “DC”")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")