const regex = /host\=\s*(?<campus_site_code>\w\d{3,5})(?<function>\w\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('host\\=\\s*(?<campus_site_code>\\w\\d{3,5})(?<function>\\w\\w)', 'gm')
const str = `1.) host=L004PS4bldDC7, the campus site code is “L004” and the function code is “PS”
2.) host= L0005DB5bldPS, the campus site code is “L0005” and the function code is “DB”
3.) host=L00006DC6rDB1, the campus site code is “L00006” and the function code is “DC”`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}