import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "host\\=\\s*(?<campus_site_code>\\w\\d{3,5})(?<function>\\w\\w)";
final String string = "1.) host=L004PS4bldDC7, the campus site code is “L004” and the function code is “PS”\n\n"
+ "2.) host= L0005DB5bldPS, the campus site code is “L0005” and the function code is “DB”\n\n"
+ "3.) host=L00006DC6rDB1, the campus site code is “L00006” and the function code is “DC”";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}