using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"host\=\s*(?<campus_site_code>\w\d{3,5})(?<function>\w\w)";
string input = @"1.) host=L004PS4bldDC7, the campus site code is “L004” and the function code is “PS”
2.) host= L0005DB5bldPS, the campus site code is “L0005” and the function code is “DB”
3.) host=L00006DC6rDB1, the campus site code is “L00006” and the function code is “DC”";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}