#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?=procedure A;)(procedure \w+;\s*(?:(?!procedure|begin|end;)[\s\S]|(?1))*(begin(?:(?!begin|end;)[\s\S]|(?2))*end;))"
Local $sString = "procedure A;" & @CRLF & _
" procedure B; " & @CRLF & _
" begin" & @CRLF & _
" end;" & @CRLF & _
" procedure C;" & @CRLF & _
" begin" & @CRLF & _
" end;" & @CRLF & _
"begin" & @CRLF & _
" if True then" & @CRLF & _
" begin" & @CRLF & _
" end;" & @CRLF & _
"end;" & @CRLF & _
"" & @CRLF & _
"procedure C;" & @CRLF & _
"begin" & @CRLF & _
"if True then" & @CRLF & _
"begin" & @CRLF & _
"end;" & @CRLF & _
"end;" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"procedure A;" & @CRLF & _
"procedure B; " & @CRLF & _
"begin" & @CRLF & _
"end;" & @CRLF & _
"procedure C;" & @CRLF & _
"begin" & @CRLF & _
"end;" & @CRLF & _
"begin" & @CRLF & _
"if True then" & @CRLF & _
"begin" & @CRLF & _
"end;" & @CRLF & _
"end;" & @CRLF & _
"" & @CRLF & _
"procedure C;" & @CRLF & _
"begin" & @CRLF & _
" if True then" & @CRLF & _
" begin" & @CRLF & _
" end;" & @CRLF & _
"end;" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")