re = /(?=procedure A;)(procedure \w+;\s*(?:(?!procedure|begin|end;)[\s\S]|(?1))*(begin(?:(?!begin|end;)[\s\S]|(?2))*end;))/mi
str = 'procedure A;
procedure B;
begin
end;
procedure C;
begin
end;
begin
if True then
begin
end;
end;
procedure C;
begin
if True then
begin
end;
end;
procedure A;
procedure B;
begin
end;
procedure C;
begin
end;
begin
if True then
begin
end;
end;
procedure C;
begin
if True then
begin
end;
end;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end