const regex = /(?=procedure A;)(procedure \w+;\s*(?:(?!procedure|begin|end;)[\s\S]|(?1))*(begin(?:(?!begin|end;)[\s\S]|(?2))*end;))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=procedure A;)(procedure \\w+;\\s*(?:(?!procedure|begin|end;)[\\s\\S]|(?1))*(begin(?:(?!begin|end;)[\\s\\S]|(?2))*end;))', 'gmi')
const str = `procedure A;
procedure B;
begin
end;
procedure C;
begin
end;
begin
if True then
begin
end;
end;
procedure C;
begin
if True then
begin
end;
end;
procedure A;
procedure B;
begin
end;
procedure C;
begin
end;
begin
if True then
begin
end;
end;
procedure C;
begin
if True then
begin
end;
end;
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}