import re
regex = re.compile(r"(?=procedure A;)(procedure \w+;\s*(?:(?!procedure|begin|end;)[\s\S]|(?1))*(begin(?:(?!begin|end;)[\s\S]|(?2))*end;))", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("procedure A;\n"
" procedure B; \n"
" begin\n"
" end;\n"
" procedure C;\n"
" begin\n"
" end;\n"
"begin\n"
" if True then\n"
" begin\n"
" end;\n"
"end;\n\n"
"procedure C;\n"
"begin\n"
"if True then\n"
"begin\n"
"end;\n"
"end;\n\n\n"
"procedure A;\n"
"procedure B; \n"
"begin\n"
"end;\n"
"procedure C;\n"
"begin\n"
"end;\n"
"begin\n"
"if True then\n"
"begin\n"
"end;\n"
"end;\n\n"
"procedure C;\n"
"begin\n"
" if True then\n"
" begin\n"
" end;\n"
"end;\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")