import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=procedure A;)(procedure \\w+;\\s*(?:(?!procedure|begin|end;)[\\s\\S]|(?1))*(begin(?:(?!begin|end;)[\\s\\S]|(?2))*end;))";
final String string = "procedure A;\n"
+ " procedure B; \n"
+ " begin\n"
+ " end;\n"
+ " procedure C;\n"
+ " begin\n"
+ " end;\n"
+ "begin\n"
+ " if True then\n"
+ " begin\n"
+ " end;\n"
+ "end;\n\n"
+ "procedure C;\n"
+ "begin\n"
+ "if True then\n"
+ "begin\n"
+ "end;\n"
+ "end;\n\n\n"
+ "procedure A;\n"
+ "procedure B; \n"
+ "begin\n"
+ "end;\n"
+ "procedure C;\n"
+ "begin\n"
+ "end;\n"
+ "begin\n"
+ "if True then\n"
+ "begin\n"
+ "end;\n"
+ "end;\n\n"
+ "procedure C;\n"
+ "begin\n"
+ " if True then\n"
+ " begin\n"
+ " end;\n"
+ "end;\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}