import Foundation
let pattern = #"(?=procedure A;)(procedure \w+;\s*(?:(?!procedure|begin|end;)[\s\S]|(?1))*(begin(?:(?!begin|end;)[\s\S]|(?2))*end;))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
procedure A;
procedure B;
begin
end;
procedure C;
begin
end;
begin
if True then
begin
end;
end;
procedure C;
begin
if True then
begin
end;
end;
procedure A;
procedure B;
begin
end;
procedure C;
begin
end;
begin
if True then
begin
end;
end;
procedure C;
begin
if True then
begin
end;
end;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)