$re = '/(?=procedure A;)(procedure \w+;\s*(?:(?!procedure|begin|end;)[\s\S]|(?1))*(begin(?:(?!begin|end;)[\s\S]|(?2))*end;))/mi';
$str = 'procedure A;
procedure B;
begin
end;
procedure C;
begin
end;
begin
if True then
begin
end;
end;
procedure C;
begin
if True then
begin
end;
end;
procedure A;
procedure B;
begin
end;
procedure C;
begin
end;
begin
if True then
begin
end;
end;
procedure C;
begin
if True then
begin
end;
end;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);