use strict;
my $str = 'procedure A;
procedure B;
begin
end;
procedure C;
begin
end;
begin
if True then
begin
end;
end;
procedure C;
begin
if True then
begin
end;
end;
procedure A;
procedure B;
begin
end;
procedure C;
begin
end;
begin
if True then
begin
end;
end;
procedure C;
begin
if True then
begin
end;
end;
';
my $regex = qr/(?=procedure A;)(procedure \w+;\s*(?:(?!procedure|begin|end;)[\s\S]|(?1))*(begin(?:(?!begin|end;)[\s\S]|(?2))*end;))/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}