# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\$+)(?:(?!\1)[\s\S])*\1//gm;t' <<< "This is an example $$a \text{$a$}$$. How to remove it? Another random math expression $\mathbb{R}$..."