re = /(\$+)(?:(?!\1)[\s\S])*\1/m
str = 'This is an example $$a \\text{$a$}$$. How to remove it? Another random math expression $\\mathbb{R}$...'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result