use strict;
my $str = 'This is an example $$a \\text{$a$}$$. How to remove it? Another random math expression $\\mathbb{R}$...';
my $regex = qr/(\$+)(?:(?!\1)[\s\S])*\1/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";