import Foundation
let pattern = #"(\$+)(?:(?!\1)[\s\S])*\1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"This is an example $$a \text{$a$}$$. How to remove it? Another random math expression $\mathbb{R}$..."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)