using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\$+)(?:(?!\1)[\s\S])*\1";
string substitution = @"";
string input = @"This is an example $$a \text{$a$}$$. How to remove it? Another random math expression $\mathbb{R}$...";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}