const regex = new RegExp('(\\$+)(?:(?!\\1)[\\s\\S])*\\1', 'gm')
const str = `This is an example \$\$a \\text{\$a\$}\$\$. How to remove it? Another random math expression \$\\mathbb{R}\$...`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);