$re = '/(\$+)(?:(?!\1)[\s\S])*\1/m';
$str = 'This is an example $$a \\text{$a$}$$. How to remove it? Another random math expression $\\mathbb{R}$...';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;