#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\$+)(?:(?!\1)[\s\S])*\1"
Local $sString = "This is an example $$a \text{$a$}$$. How to remove it? Another random math expression $\mathbb{R}$..."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)