#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[a-z][a-z\d]*(?:_[a-z\d]+)*$"
Local $sString = "_" & @CRLF & _
"A" & @CRLF & _
"abcd" & @CRLF & _
"a_2_c_3" & @CRLF & _
"aB_C" & @CRLF & _
"1abc" & @CRLF & _
"ab__c" & @CRLF & _
"a_b_" & @CRLF & _
"Humpty Dumpty" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")