$re = '/^[a-z][a-z\d]*(?:_[a-z\d]+)*$/mi';
$str = '_
A
abcd
a_2_c_3
aB_C
1abc
ab__c
a_b_
Humpty Dumpty
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);