const regex = /^[a-z][a-z\d]*(?:_[a-z\d]+)*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z][a-z\\d]*(?:_[a-z\\d]+)*$', 'gmi')
const str = `_
A
abcd
a_2_c_3
aB_C
1abc
ab__c
a_b_
Humpty Dumpty
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}