package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[a-z][a-z\d]*(?:_[a-z\d]+)*$`)
var str = `_
A
abcd
a_2_c_3
aB_C
1abc
ab__c
a_b_
Humpty Dumpty
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}