# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|\D)(\d)($|\D)/$10$2$3/gm;t' <<< "2:5
4:15
21:26
14:7
8:2
"