using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\D)(\d)($|\D)";
string substitution = @"$10$2$3";
string input = @"2:5
4:15
21:26
14:7
8:2
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}