import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|\\D)(\\d)($|\\D)";
final String string = "2:5\n"
+ "4:15\n"
+ "21:26\n"
+ "14:7\n"
+ "8:2\n";
final String subst = "$10$2$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}